Oracle WebLogic and Forms 11g Setup Prerequisites for IBM-AIX on POWER Systems

1.     Minimum System Requirements

1.1.    Supported Operating Systems:

1.1.1. IBM AIX 5.3 UL8+

1.1.2. IBM AIX 6.1 UL7+

1.1.3. IBM AIX 7.1 UL1+

1.2.    RAM: 8GB+

1.3.    HDD Partitioning:

*Software Mount: One file system mount with at least 50GB of free space to store the software and temporary file storage for servers.

TEMPFS Space: 4GB+ (Minimum: 1GB+)

*SWAP: 8GB+

1.4.    OS User Access Requirements:

1.4.1. OS User will need to own the software mount.

1.4.2. Root user access must be accessible for the installation.

*RAM and File System Mount Specifications: For production systems, please consult PITSS or Oracle on sizing recommendations. The amount of RAM, HDD Space for SWAP and Software Mounts will vary depending on end-user usage and application characteristics. If you will be running reports heavily, use at least 20GB of SWAP.

2.     Other AIX OS Requirements

2.1.    Open File Limits:

“soft nofile” should be atleast 4096
“hard nofile” should be atleast 4096 (65535 is recommended)

3.     Required Packages

3.1.1.  IBM AIX 5.3 64-bit

The minimum versions of the packages below will need to be installed before the Forms 11g installation can begin:

Package Name

bos.adt.base

bos.adt.lib

bos.adt.libm

bos.perf.libperfstat

bos.perf.perfstat

bos.perf.proctools

rsct.basic.rte

rsct.compat.clients.rte

bos.mp64 (version 5.3.0.56)

bos.rte.libc (version 5.3.0.55)

xlC.aix50.rte (version 8.0.0.7)

xlC.rte (version 8.0.0.7)

X11.motif.lib (version 2.1.30)

gpfs.base (version 3.2.1.8) (Only if using Oracle RAC)

3.1.2.  IBM AIX 6.1 64-bit

The minimum versions of the packages below will need to be installed before the Forms 11g installation can begin:

Package Name

bos.adt.base

bos.adt.lib

bos.adt.libm

bos.perf.libperfstat

bos.perf.perfstat

bos.perf.proctools

rsct.basic.rte

rsct.compat.clients.rte

xlC.aix50.rte (version 11.1.0.4)

xlC.rte (version 11.1.0.4)

X11.motif.lib (version 2.1.30)

gpfs.base (version 3.2.1.8) (Only if using Oracle RAC)

For more information from Oracle on required packages please go to: http://download.oracle.com/docs/html/E18558_01/fusion_requirements.htm#BABIDAAA

3.1.3.  IBM AIX 7.1 64-bit

The minimum versions of the packages below will need to be installed before the Discoverer 11g installation can begin:

Package Name

bos.adt.base

bos.adt.lib

bos.adt.libm

bos.perf.libperfstat

bos.perf.perfstat

bos.perf.proctools

rsct.basic.rte

rsct.compat.clients.rte

xlC.aix50.rte (version 10.1.0.0)

xlC.rte (version 10.1.0.0)

IZ89165 (Only if using Oracle BI)

For more information from Oracle on required packages please go to: http://download.oracle.com/docs/html/E18558_01/fusion_requirements.htm#BABIDAAA

4.     Database Requirements

4.1.    Supported Database Versions:

10.2.0.4+

11.1.0.7+

11.2.0.1+

12.1.0.1+

4.2.    A database user with DBA/SYS privileges accessible.

4.3.    The file tnsnames.ora containing the SID of the database will need to be placed in the server/client in the same location as the other prerequisites.

5.     Software Requirements

5.1.    IBM JDK 7 (SR3 or higher)

5.2.    Webutil and JACOB

5.2.1. Please contact PITSS at 248-740-0935 or pitssam-support@pitss.com for download instructions.

5.3.    For an 11g Forms installation you will need to download the following software:

5.3.1. WebLogic 10.3.6

5.3.1.1.              Can be downloaded from: http://www.oracle.com/technetwork/middleware/ias/downloads/wls-main-097127.html

5.3.1.2.              After accepting the license agreement, scroll down to Oracle WebLogic Server 10.3.6. Do NOT install 12c. You will see a plus box next to “Oracle WebLogic Server 10.3.6”. Click the plus box next to “See all files” and more options will be available.

clip_image002[4]

5.3.1.3.              The ‘Oracle WebLogic Server 11gR1 (10.3.6) Coherence – Package Installer’ is the recommended installer of choice.

5.3.1.4.              Please download the file that corresponds to your system OS.  Note for 64-bit AIX, the “Generic” Installer will need to be downloaded.

clip_image004[4]

5.3.2. Forms 11.1.1.2

5.3.2.1.              Oracle Forms 11.1.1.2.0 is no longer available on OTN. It can only be downloaded from the Oracle E-Delivery page at:

https://edelivery.oracle.com

5.3.2.2.              Once there, search for the Product Pack “Oracle Fusion Middleware” on Platform “IBM AIX on POWER Systems (64-bit). Next, click on the description link for “Oracle Fusion Middleware 11g Media Pack for IBM AIX on POWER Systems (64-bit).” It will take you to a new page.

5.3.2.3.              Scroll down until you see the six downloads highlighted in the screenshot below. Please download the setup files that correspond to your system OS:

clip_image006[4]

5.3.3. Forms 11.1.1.7

The following steps will help guide you through Oracle’s Support website to find the Forms 11.1.1.7 Patch set. This is the only Oracle Website location where the Forms 11.1.1.7 Patch set can be downloaded.

5.3.3.1.              Go to support.oracle.com

5.3.3.2.              Login with your Oracle OTN Login that has your organization’s “oracle support identifier” that lets you download “Patches & Updates”

5.3.3.3.              Click on “Patches & Updates

clip_image008[4]

5.3.3.4.              In the Patch search, type in the patch number 16471668. Click the + button to the right to expand.

5.3.3.5.              For Platform, select “IBM AIX on POWER Systems (64-bit)”. Once checked, click “Search”.

clip_image010[4]

5.3.3.6.              The Patchset will appear. Click on the patch number.

clip_image012[4]

5.3.3.7.              Click “Download”.

clip_image014[4]

5.3.3.8.              Click on the links to download. The patch set is approximately 2.1 GB in file size, thus the files may take a decent amount of time to download.

clip_image016[4]

If you have any questions on the above, please contact PITSS for questions.

Get Our Newsletter