Oracle Access Manager (OAM) 11g Prerequisites for Solaris

1.  Minimum System Requirements

1.1.  Supported Operating Systems

1.1.1. Solaris 10 Update 9+ SPARC

1.1.2. Solaris 11 SPARC: All levels supported

1.1.3. Solaris 10 Update 9+ 64-bit

1.1.4. Solaris 11 64-bit: All levels supported

1.2.  *RAM: 8 GB+ (20 GB+ minimum for production environments)

1.3.  File System Mount Requirements:

*Software Mount: One file system mount with at least 80GB free space to store the software

TMPFS space: 4GB+ (Minimum: 1 GB)

*SWAP: 8GB+

Heap space: 8 GB

1.4.  OS User Access Requirements:

1.4.1. OS user to own the software mount

1.4.2. Root user access must be accessible for the installation.

1.5.  IPv6 must be disabled on your network adapter before OAM can be installed. IPv6 is not supported with OAM.

*RAM and File System Mount Specifications: For production systems, please consult PITSS or Oracle on sizing recommendations. The amount of RAM, HDD Space for SWAP and Software Mounts will vary depending on end-user usage and application characteristics. For production environments, a minimum of 20 GB of RAM is required: 4 GB for the WebLogic servers and at least 16 GB for performance for up to 1,000,000 users. Oracle Support note 1468111.1 contains more information.

2.  Other Unix OS Requirements

2.1.  The operating system needs to set Native POSIX Threads Library (NPTL) as the default threads-implementation. To check for us, run the following command:

getconf GNU_LIBPTHREAD_VERSION

The expected results should be: NPTL 2.3.4 or higher.

2.2.  Open File Limits:

“soft nofile” should be atleast 4096
“hard nofile” should be atleast 4096 (65535 is recommended)

3.  Required Packages

Below is a list of packages/libraries that need to be installed prior to installing 11g Forms and Reports. Please note the difference between the processor and release types:

10u6+ for x86_64

11 for SPARC and x86_64

SUNWarc

SUNWlibC

SUNWbtool

GCC: 3.4.2+

SUNWhea

 

SUNWlibC

 

SUNWlibm

 

SUNWlibms

 

SUNWsprot

 

SUNWtoo

 

SUNWi1of

 

SUNWi1cs (ISO8859-1)

 

SUNWi15cs (ISO8859-15)

 

SUNWxwfnt

 

Motif: 2.1.0+

 

GCC: 3.4.2+

 

 

 

The following environment variables must be set in your profile:

 

  • Solaris x86_64: export NLS_LANG=AMERICAN_AMERICA.WE8ISO8859P15 or set the DISPLAY variable to any 64-bit Linux machine
  • Solaris SPARC:
    • export LC_ALL=C
    • export NLS_LANG=AMERICAN_AMERICA.WE8ISO8859P15 or set the DISPLAY variable to any 64-bit Linux machine

For more information from Oracle on required package information please go to: http://docs.oracle.com/html/E18558_01/fusion_requirements.htm#BABDGCFA

4.  Database Requirements

4.1.  Database Software

A database for OAM 11g will be needed to store the OAM Repository

Supported Database Versions:

10.2.0.4+

11.1.0.7+

11.2.0.1+

4.2.  A database user with DBA/SYS privileges will need to be accessible.

4.3.  The file tnsnames.ora containing the SID of the database will need to be placed in the server/client in the same location as the other prerequisites.

4.4.  Database Character Set: AL32UTF8

4.5.  Database Parameter Requirements:

·  ag_tm_rpcoesses >= 1

·  db_cache_size >=144M

·  java_pool_size >= 120M

·  shared_pool_size >= 175M

·  open_cursors >= 500

·  db_block_size: 8KB

·  processes >= 500

·  pga_aggregate_target >= 96M

5.  Software Requirements

5.1.  Java JDK 1.7.0_21 (or latest version of Java JDK 7)

5.1.1. Go to http://www.oracle.com/technetwork/java/javase/downloads/jdk7-downloads-1880260.html

5.1.2. Click on “jdk-7u21-solaris-x64.tar.gz for 64-bit” or “jdk-7u21-solaris-sparcv9.tar.gz for SPARC”

NOTE: This is the page to download the latest JDK version.

clip_image001

NOTE: Java JDK  1.7.0_07 is the minimum required for OAM 11.1.1.7.0 if using Oracle WebLogic Server 10.3.6, but we recommend the latest version of JDK (1.7.0_21+ as it is more current and contains critical security updates.

For UNIX-Based systems we recommend to install this prior to the OAM installation.

 

5.2.  WebLogic 10.3.6

5.2.1. Can be downloaded from: http://www.oracle.com/technetwork/middleware/ias/downloads/wls-main-097127.html

5.2.2. After accepting the license agreement, scroll down to Oracle WebLogic Server 10.3.6. Do NOT install 12c. You will see a plus box next to “Oracle Weblogic Server 10.3.6”. Click the plus box next to “See all files” and more options will be available.

clip_image003

5.2.3. The “Oracle WebLogic Server 11gR1 (10.3.6) + Coherence Package Installer” is the recommended installer of choice.

5.2.4. Please download the file that corresponds to your system OS.  Note for 64-bit Unix and Windows, the “Generic” Installer will need to be downloaded.

clip_image005

 

5.3.  Oracle Identity and Access Management 11.1.1.7.0

5.3.1. Can be downloaded from:

http://www.oracle.com/technetwork/middleware/downloads/oid-11g-161194.html

After accepting the license agreement, please download the setup files that correspond to your system OS.

clip_image007

5.4.  Oracle Identity Management 11.1.1.7.0

5.4.1. Can be downloaded from: http://www.oracle.com/technetwork/middleware/downloads/oid-11g-161194.html
After accepting the license agreement, please download the setup file that pertains to your operating system.

clip_image009

 

 

5.5.  Repository Creation Utility 11.1.1.7.0

IMPORTANT: RCU is NOT supported to be run from Solaris. RCU is only used to install database schemas for OAM and OID. Access to a Windows or Linux environment is mandatory to run the RCU installer only.

5.5.1. Can be downloaded from:

http://www.oracle.com/technetwork/middleware/bi-enterprise-edition/downloads/bi-downloads-1923016.html

5.5.2. Scroll down until you see “Required Additional Software”. In this section, it will show download links for the Repository Creation Utility 11.1.1.7.0. NOTE: We will not be installing Oracle Business Intelligence 11g.

5.5.3. After accepting the license agreement, please download the setup files that correspond to your system OS.

clip_image010

 

 

5.6.  Oracle WebTier Utilities 11.1.1.7

5.6.1. Can be downloaded from:

http://www.oracle.com/technetwork/java/webtier/downloads/index2-303202.html

clip_image011

clip_image012

 

 

5.7.  Oracle Access Manager WebGates 11.1.1.7.0

5.7.1. Can be downloaded from:

http://www.oracle.com/technetwork/middleware/downloads/oid-11g-161194.html

After accepting the license agreement, please download the setup files that correspond to your system OS.

clip_image014

If you have any questions on the above, please contact PITSS.